A2DP lost - BMW K1600 Forum : BMW K1600 GT and GTL Forums
 
LinkBack Thread Tools
post #1 of 9 Old 06-29-2019, 04:58 AM Thread Starter
Senior Member
 
IanI's Avatar
 
Join Date: May 2015
Location: God's own Country
Posts: 434
Garage
Send a message via Skype™ to IanI
A2DP lost

A problem has developed on my 2017 K1600 gtl.
I have a Nav 6 and a system 6 helmet with a BMW Communicator fitted.
I used to be able to play music from the Nav to the helmet. Now when I try I get an error telling me I need an A2DP device connected.
All the other sounds, navigation directions, beeps etc. come through fine.

I have paired and repaired several times but it remains the same.
I can play music from the bike to the helmet.
When the helmet is connected to the Nav 6 and I look under the Bluetooth settings it show the helmet connected but the music icon next to the helmet is greyed out.
I went to the dealer and he connected his system 7 helmet with the newer BMW comminicator and the music icon was blue as it should be.
We connected my helmet to his Nav 6 and the music icon was greyed out.
I have my android phone connected to the Nav and the music icon is blue.

I am thinking the helmet communicator may have developed a fault, however the collective wisdom on here may know better!

Any suggestions welcome.

Eccentric and proud
IanI is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 06-29-2019, 05:32 AM
Senior Member
 
Mole999's Avatar
 
Join Date: Jan 2016
Location: UK
Posts: 2,464
Garage
any recent phone updates

R80/7RT / K75RT / R1200RT / K1600 GTL - in the U.K.
Also Rans ( Honda C90 & CD175 & CX500 & ST1100, Suzuki GT250 (J) & X7, Puch Maxi), Coveted Honda CBX, Yamaha Martini XS 1300 & FS1E, Kawasaki Z900, Z1000 & Z650, Quasar, Suzuki GT750
Mole999 is offline  
post #3 of 9 Old 06-29-2019, 07:54 AM
Senior Member
 
ViennaK's Avatar
 
Join Date: Jun 2014
Location: Goettingen Germany
Posts: 2,648
Garage
Could be that the BMW BT audio took the available A2DP connection of the BMW headset. My suggestion is to delete all pairings on the headset, NAV6 and BMW BT. Turn off BMW BT, then pair BMW headset first with the navigator and then to the BMW BT.
Worth a try.

2018 BMW K1600 GT
2018 BMW K1600 GTL (sold)

2014 BMW K1600 GTL (sold)
2005-2014 5 HD ElectraGlides (sold)
2003 HD Softail (sold)
1973-1982 various jalopies (gone)


'You know that the world is going to h€ll if they have to print instructions on a bag of toothpicks'
After Douglas Adams RIP
ViennaK is online now  
Sponsored Links
Advertisement
 
post #4 of 9 Old 06-29-2019, 08:52 AM
Senior Member
 
Join Date: Jul 2018
Location: Metro Atlanta, GA, USA
Posts: 906
^ +1 - Agree with ViennaK - Sounds like you need to "clean up" how your devices are paired to one another.

I would suggest you keep it simple by deleting all your pairings and then add 1 device at a time to see how it links up.

If the music feature is anything like the phone feature, it will not handle 2 devices at the same time. For example, if I pair my phone to my Nav and my phone to my Sena, normally the phone features are turned off on the Nav and I can only use my Sena for the phone features. I prefer using my Nav for the phone features, so I unpaired my phone from my Sena and the phone works fine when paired only with the Nav.

My setup is bike radio to Sena, Nav to Sena, phone to Nav. Having the bike radio paired to the Sena means I can use the thumbwheel for radio stations and control the volume from the Sena.



Current Bike: '18 K1600B

Most recent former bikes:
'14 R1200RT
'13 F800GT
WillH is online now  
post #5 of 9 Old 06-29-2019, 10:12 AM
Senior Member
 
BMWGuy's Avatar
 
Join Date: Nov 2015
Location: Apple Valley, MN
Posts: 1,544
Quote:
Originally Posted by WillH View Post
My setup is bike radio to Sena, Nav to Sena, phone to Nav. Having the bike radio paired to the Sena means I can use the thumbwheel for radio stations and control the volume from the Sena.
While I don't use SENA headset, my set up is paired exactly the same. I use the BMW SRC.

Joe

“Fate whispers to the warrior, 'You can not withstand the storm.'
The warrior whispers back, 'I am the storm.'
BMWGuy is online now  
post #6 of 9 Old 06-30-2019, 03:45 PM Thread Starter
Senior Member
 
IanI's Avatar
 
Join Date: May 2015
Location: God's own Country
Posts: 434
Garage
Send a message via Skype™ to IanI
Quote:
Originally Posted by ViennaK View Post
Could be that the BMW BT audio took the available A2DP connection of the BMW headset. My suggestion is to delete all pairings on the headset, NAV6 and BMW BT. Turn off BMW BT, then pair BMW headset first with the navigator and then to the BMW BT.
Worth a try.

Done all that - deleted all pairings on everything.

Eccentric and proud
IanI is offline  
post #7 of 9 Old 07-01-2019, 12:44 AM
Senior Member
 
ViennaK's Avatar
 
Join Date: Jun 2014
Location: Goettingen Germany
Posts: 2,648
Garage
Active BT connection between BMW com and NAV 6 should show 'media' activated check mark on the NAV 6 BT settings tab. Do you see that? If not enable it.

2018 BMW K1600 GT
2018 BMW K1600 GTL (sold)

2014 BMW K1600 GTL (sold)
2005-2014 5 HD ElectraGlides (sold)
2003 HD Softail (sold)
1973-1982 various jalopies (gone)


'You know that the world is going to h€ll if they have to print instructions on a bag of toothpicks'
After Douglas Adams RIP
ViennaK is online now  
post #8 of 9 Old 07-02-2019, 08:23 AM Thread Starter
Senior Member
 
IanI's Avatar
 
Join Date: May 2015
Location: God's own Country
Posts: 434
Garage
Send a message via Skype™ to IanI
Quote:
Originally Posted by ViennaK View Post
Active BT connection between BMW com and NAV 6 should show 'media' activated check mark on the NAV 6 BT settings tab. Do you see that? If not enable it.
If I go to the setting to enable it it says 'Media not in range' and is greyed out.

Eccentric and proud
IanI is offline  
post #9 of 9 Old 07-02-2019, 09:38 AM
Senior Member
 
ViennaK's Avatar
 
Join Date: Jun 2014
Location: Goettingen Germany
Posts: 2,648
Garage
Did you try to pair your headset only to the Nav with the BMW BT off?
Just another part of elimination. If you have the latest firmware, all pairings renewed in the right order it should work unless there is a defect of your headset.
ViennaK is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW K1600 Forum : BMW K1600 GT and GTL Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome