Uni-go trailer question - BMW K1600 Forum : BMW K1600 GT and GTL Forums
 23Likes
Reply
 
LinkBack Thread Tools
post #1 of 40 Old 09-17-2018, 05:24 PM Thread Starter
Member
 
Join Date: Feb 2018
Posts: 86
Garage
Uni-go trailer question

I recently bought a 2004 Uni-go and have a couple questions:


On their website they list a BMW canbus adapter, is this necessary?


Where and how did you tap into the wiring for the trailer lights?


Where did you mount the wiring plug on the bike?


Any help would be appreciated and maybe a photo or two would be great.


Dan
daniel1502 is online now  
Sponsored Links
Advertisement
 
post #2 of 40 Old 09-17-2018, 06:37 PM
Senior Member
 
Gunnert's Avatar
 
Join Date: Sep 2012
Location: Catlett, VA
Posts: 5,807
Yes, it's necessary. I used an Isolator from Electrical Connections to tap into the K bike's electrics. I tapped in under the right hand shroud/canoe by the rear seat using posi-taps. Do a search of the forum to find which wires go where. The Isolator gets input from the K bike's wiring and provides output for the trailer circuits. I attached the Unigo electrical connector to the left side plate of the BushTec hitch with rivets. PM me your cell phone and I'll text you a photo of the wiring plug.

Duane

Duane: '12 K1600GT/WL EngineBars//Wilbers/VarioLevers/ cbdaneAmber /BajaDesigns LED/PDM60/Remus Headers/GPR Exhaust/BST Carbon Fiber Wheels
Gunnert is online now  
post #3 of 40 Old 09-17-2018, 07:31 PM
Senior Member
 
mlheck's Avatar
 
Join Date: May 2016
Posts: 537
Garage
Just to add to the above post. The isolator must be connected to the battery or other power source. It then uses the signal from the lights to trigger relays that use the power source to light the trailer lights and not the bike's wiring harness. This is how you avoid a Can-bus error.

Also the color code for the wires changed on the '18 bikes.

Sent using Tapatalk

"I know I was born, I know that I will die, the in between is mine" Pearl Jam
mlheck is online now  
Sponsored Links
Advertisement
 
post #4 of 40 Old 09-18-2018, 05:48 AM
Senior Member
 
EpcotPhil's Avatar
 
Join Date: Oct 2016
Location: Orlando Florida area
Posts: 157
Garage
The lighting question has another solution: if you are already using a Skene controller to flicker and pulse the tail lights, and you replace the Unigo incandescent bulbs with LEDs, the Skene controller can drive the extra load without the Beemer noticing.

I mounted the cable connector to the rear fender (see pict) and with @Gunnert ís suggestion, shortened the hitch to reduce wobble. Just got back from a 1700 mile trip with mountain roads and speeds up to 80 with no stability issues at all.

Yes, you notice itís there and backing up takes some practice but the effects are subtle. Biggest one I notice is a delayed roll torque if you do quick leans. Driving smoothly pretty much eliminates.

Good luck and letís see some pictures of the finished product!



Gunnert, J-Luv, 03Camjob and 3 others like this.
EpcotPhil is offline  
post #5 of 40 Old 09-18-2018, 11:57 AM Thread Starter
Member
 
Join Date: Feb 2018
Posts: 86
Garage
After my initial post and Duane (Gunnert) responded I sent him my phone number since he said he would send me some pictures of his setup which he did. Then to my surprise he called me to explain further which was a great help, thanks again Duane. And again, thank you all for your help, suggestions and advise.
Gunnert, capav8r and Prince like this.
daniel1502 is online now  
post #6 of 40 Old 09-18-2018, 12:23 PM
Senior Member
 
Gunnert's Avatar
 
Join Date: Sep 2012
Location: Catlett, VA
Posts: 5,807
@EpcotPhil , how about posting p/n and where you got the LED bulbs from?

Duane

Duane: '12 K1600GT/WL EngineBars//Wilbers/VarioLevers/ cbdaneAmber /BajaDesigns LED/PDM60/Remus Headers/GPR Exhaust/BST Carbon Fiber Wheels
Gunnert is online now  
post #7 of 40 Old 09-18-2018, 08:13 PM
Senior Member
 
ResQU's Avatar
 
Join Date: Oct 2015
Location: Bakersfield, California
Posts: 579
Garage
I replaced all the lights with LEDís from https://www.superbrightleds.com
Gunnert likes this.

I honestly try to not ride faster than my guardian angel can fly , however....I know it's pooped by end of the ride
ResQU is offline  
post #8 of 40 Old 09-19-2018, 06:33 AM
Senior Member
 
Gunnert's Avatar
 
Join Date: Sep 2012
Location: Catlett, VA
Posts: 5,807
@ResQU , a little more help? The bulb numbers out of my Unigo don't appear to cross over to the LEDs in your link. Which ones did you actually buy? Can you confirm the brake light is a 1157 and turn signals 1142?

Duane

Duane: '12 K1600GT/WL EngineBars//Wilbers/VarioLevers/ cbdaneAmber /BajaDesigns LED/PDM60/Remus Headers/GPR Exhaust/BST Carbon Fiber Wheels

Last edited by Gunnert; 09-19-2018 at 07:14 AM.
Gunnert is online now  
post #9 of 40 Old 09-19-2018, 10:24 AM
Senior Member
 
ResQU's Avatar
 
Join Date: Oct 2015
Location: Bakersfield, California
Posts: 579
Garage
@Gunnert Sure....Yes the brake is an 1157. The turn signal on mine is not an 1142. They have a blade type base. These are the bulbs I am using:

Brake: https://www.superbrightleds.com/more...car/1166/2761/
Turn: https://www.superbrightleds.com/more...car/1129/2685/ (if yours are 1142, there is a cross over bulb but it isn’t in the CANBUS line here) https://www.superbrightleds.com/more...ens/2395/2255/
License Plate: https://www.superbrightleds.com/more...car/1127/2673/
Interior: https://www.superbrightleds.com/more...edirect_disc=0 (this one has been discontinued but there is a suggested replacement in the link)

I honestly try to not ride faster than my guardian angel can fly , however....I know it's pooped by end of the ride

Last edited by ResQU; 09-19-2018 at 10:52 AM.
ResQU is offline  
post #10 of 40 Old 09-19-2018, 11:42 AM
Junior Member
 
Angel's Avatar
 
Join Date: Sep 2013
Posts: 28
Garage
FWIW,
I have a slightly older UniGo (NZ model) on my 2013GT with a K1600 GTL hitch purchased from dmcsidecars.com. The hitch came with a wiring harness. I cant recall at the moment if the DMC harness came with the canbus adaptor you are asking about. But I know that I installed it per the instructions and have not had any problems with it.
Angel is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW K1600 Forum : BMW K1600 GT and GTL Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome