Shift assist failed - BMW K1600 Forum : BMW K1600 GT and GTL Forums
 22Likes
Reply
 
LinkBack Thread Tools
post #1 of 109 Old 07-01-2018, 01:37 PM Thread Starter
Senior Member
 
ViennaK's Avatar
 
Join Date: Jun 2014
Location: Goettingen Germany
Posts: 2,646
Garage
Shift assist failed

Shift assist stopped working at around 21000 km on my 2018 MY GTL. Experienced some hard shifting occasionally, but now it is completely out of order. Nice in way that I can go back to normal shifting. Bike will go back to the dealer a few days after the 20.000 service was done, timing sucks.

2018 BMW K1600 GT
2018 BMW K1600 GTL (sold)

2014 BMW K1600 GTL (sold)
2005-2014 5 HD ElectraGlides (sold)
2003 HD Softail (sold)
1973-1982 various jalopies (gone)


'You know that the world is going to hll if they have to print instructions on a bag of toothpicks'
After Douglas Adams RIP

Last edited by ViennaK; 07-02-2018 at 11:57 AM.
ViennaK is online now  
Sponsored Links
Advertisement
 
post #2 of 109 Old 07-07-2018, 05:21 AM Thread Starter
Senior Member
 
ViennaK's Avatar
 
Join Date: Jun 2014
Location: Goettingen Germany
Posts: 2,646
Garage
Update on the shift assist

Well, after about one week of trying to make it work (replaced SA actuator, checked the interlocks like clutch sensors etc.) BMW found out that they cannot teach the BCM (a module that controls a large number of function of the bike outside the scope of the ECM) which in turn does not allow the SA to function properly. Mothership is involved, but no answer yet. Took the bike with the reassurance that it will be perfectly OK to take it on my vacation trip. Off I go now with the bad feeling in my head, that something in the hidden parts of electronics is screwed up and will bite my in the ass at the most inconvenient time.
BMW has a problem with quality control for sure.
K16guy and Billy S like this.

2018 BMW K1600 GT
2018 BMW K1600 GTL (sold)

2014 BMW K1600 GTL (sold)
2005-2014 5 HD ElectraGlides (sold)
2003 HD Softail (sold)
1973-1982 various jalopies (gone)


'You know that the world is going to hll if they have to print instructions on a bag of toothpicks'
After Douglas Adams RIP
ViennaK is online now  
post #3 of 109 Old 07-07-2018, 06:03 AM
Sorry to hear you're having such a problem. Computer to computer communication is a hard thing to diagnose, especially when their manual sucks, and the techs don't know squat about how to diagnose the problems. A one week class from a good instructor could do wonders for most of these techs. GM has an awesome training program that is not only available for techs, but can be accessed for free online by most anyone willing to register for the classes. I've been to a few BMW car training programs that consisted of an 8 hour, one day course, and it can be overwhelming trying to cover so much material in such a short amount of time. The hands on part of the classes were mainly watching the instructor do testing on a car that was practically new and had no real problems, except for those intentionally put into it for the class. Ask your tech sometime what he found when he checked the hi and low circuits for the can. Doubt the tests were ever done.
Best of luck with this. Let us know how it goes.

Darryl - Thanks for all you do!
RETIRED!
14BMWK1600GTL DGM
16BMWS1000XR Red
07HD FLHTCU Champion Trike
81CB750Bentforks$500
81 CB900 10speed 100HPOriginal $2.5K
81 CBX Orig 3Kmi 105HP $8K
81 CBX Frankenstein Trike $12K
1955 1st Chevy 3100 Pickup $30K
05 BMW X5
1990 Chevy 4x4
2001 Chevy Silverado 4x4
Coffintrailer $1K
Harleymarlboroman is offline  
Sponsored Links
Advertisement
 
post #4 of 109 Old 05-10-2019, 02:59 PM
Senior Member
 
justcharlie's Avatar
 
Join Date: Jul 2018
Location: Bainbridge Island, WA
Posts: 471
Did you ever get resolution on this? I was out riding today with just under 3K miles on my 2018 GTL and the shift assist just quit working. Shifted normally with the clutch. Stopped and turned bike off and started up again and shift assist was working again. It happened twice during a ~30 mile ride, lots of shifting up and down.

I haven't yet bought a GS911, so I don't know if this would throw a fault code; but it sure seems like it's related to firmware since it corrects when the bike is restarted. Dealership is over an hour away, so hard to just pop in if it happens again.

I'm also wondering if it might be the clutch sensor switch.

'18 GTL ebony metallic
added: Altrider engine bars, Ilium rear bars, Clearwater Darla and Billie brake lights

Last edited by justcharlie; 05-10-2019 at 03:02 PM.
justcharlie is offline  
post #5 of 109 Old 05-10-2019, 04:56 PM Thread Starter
Senior Member
 
ViennaK's Avatar
 
Join Date: Jun 2014
Location: Goettingen Germany
Posts: 2,646
Garage
After several weeks of tearing into the bike again the dealership concluded that it was a broken wire in the harness. In the mean time I decided to give up on this bike and traded it in for a 2018 GT. They worked with me and took the bike back.The financial impact was manageable and the GT performs without a flaw.

2018 BMW K1600 GT
2018 BMW K1600 GTL (sold)

2014 BMW K1600 GTL (sold)
2005-2014 5 HD ElectraGlides (sold)
2003 HD Softail (sold)
1973-1982 various jalopies (gone)


'You know that the world is going to hll if they have to print instructions on a bag of toothpicks'
After Douglas Adams RIP
ViennaK is online now  
post #6 of 109 Old 05-10-2019, 06:43 PM
Senior Member
 
Join Date: Nov 2017
Location: Southern Utah
Posts: 190
Garage
Mine seems to be going out too. '18 GTL with 32,000. Pretty much every time now it starts out working and then quits at some point.
Mad Max is online now  
post #7 of 109 Old 05-10-2019, 09:21 PM
Senior Member
 
justcharlie's Avatar
 
Join Date: Jul 2018
Location: Bainbridge Island, WA
Posts: 471
Quote:
Originally Posted by Mad Max View Post
Mine seems to be going out too. '18 GTL with 32,000. Pretty much every time now it starts out working and then quits at some point.
At least if it's consistent, you can show the dealership. Should be under warranty for you. If you take it in, let me know what they say it is. Mine's under warranty, but I'm not sure I can show it fail for the dealership.

'18 GTL ebony metallic
added: Altrider engine bars, Ilium rear bars, Clearwater Darla and Billie brake lights
justcharlie is offline  
post #8 of 109 Old 05-10-2019, 09:40 PM
Senior Member
 
Join Date: Aug 2018
Location: Newmarket, Ontario
Posts: 113
2018 bagger I'm at 12,000 km and the quick shift stopped by 2000 km ago I haven't brought it in yet to be looked at

Sent from my Pixel 3 XL using Tapatalk

Current bikes

2018 K1600B
2012 Suzuki M109R
BruceWayne is offline  
post #9 of 109 Old 05-10-2019, 11:19 PM
Senior Member
 
Donna's Avatar
 
Join Date: Feb 2018
Location: Canberra, Australia
Posts: 630
Garage
I should check mine as I dont know if its working. I still match revs when I clutchless shift, up and down and have been doing that for decades now. It's second nature, purely automatic...

Donna
(Its all fun until I break a nail!)
Pink and Black K1600B
Donna is online now  
post #10 of 109 Old 05-11-2019, 06:57 AM
Senior Member
 
Join Date: Aug 2018
Posts: 549
@justcharlie It may not generate a code but chances are the ECU will note a failure and some basic data like mileage, time code and the number of times detected.
K16guy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW K1600 Forum : BMW K1600 GT and GTL Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome