K1600 GA Dead - Page 4 - BMW K1600 Forum : BMW K1600 GT and GTL Forums
 17Likes
Reply
 
LinkBack Thread Tools
post #31 of 31 Old 09-28-2019, 03:15 PM Thread Starter
Senior Member
 
mlheck's Avatar
 
Join Date: May 2016
Posts: 579
Garage
Quote:
Originally Posted by Dan Costandi View Post
Congrats on the resurrection. The fault the mechanic found is quite disturbing. Any idea why that fuse box would get so corroded? The bike isn't that old. Any chance the battery leaked onto it?
That's what my buddy asked also. The mechanic seemed to think that it was a bad connector from the start.

Sent using Tapatalk
Bluenoser likes this.

"I know I was born, I know that I will die, the in between is mine" Pearl Jam
mlheck is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW K1600 Forum : BMW K1600 GT and GTL Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome