BMW K1600 Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
After moving, I just can't find the programming cable for my Rowe Electronics PDM60 and was hoping to make some changes.
Are there any forum members who might loan me theirs for a week?
 

·
Registered
Joined
·
1,505 Posts
I also have one but shipping from Canada may be expensive/slow
 

·
Registered
Joined
·
529 Posts
Sorry for the delay in getting back to you, running Emergency Departments in the era of COVID really cuts into motorcycle related time (should have retired last year!). I have found the cable (something my wife never thought I would be able to do) let me know how to get it to you.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #7
Sorry for the delay in getting back to you, running Emergency Departments in the era of COVID really cuts into motorcycle related time (should have retired last year!). I have found the cable (something my wife never thought I would be able to do) let me know how to get it to you.
Thank you sir! Let me know the postage amount and I'll paypal it to you. And thank you for providing your health services during this difficult time. You ARE appreciated.

Kevin Hawkins
164 Fox Den Cir
Statesville, NC 28677
 

·
Mr.Fix It
Joined
·
7,065 Posts
@KHawk , you're a patient man. I'd have spent the $40 bucks and ordered one.

Duane
 
  • Like
Reactions: coyotek

·
Registered
Joined
·
75 Posts
Discussion Starter #12
:)The PDM60 is working fine. I just wanted to program some on-off delay changes. I'll also take the opportunity to document the pin-out so I can make my own for < $10. It's not the money savings as much as a simple challenge.
 

·
Premium Member
Joined
·
27 Posts
Crazy, my PDM crapped out yesterday. Spoke to Rowe, today, they said looks like unit was reprogrammed, and the grey wire is now being used as a ground... The cable is on its way to NJ, but is packed in a box, and I won’t get back for couple weeks. I am waiting patiently, but probably will buy another, and use it on another bike.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #18
So, I disconnected the power lead from my Rowe PDM60 and connected the PDM programming cable from my laptop's USB port to the bottom of the PDM60 as shown in their documentation. Nothing. The lights are supposed to flash, then select the interface type and Serial Port. All very simple. No matter what I tried, the PDM60 would not go into programming mode. So, I dropped it off at the post office Saturday morning.

I can't thank you enough for your generosity @cruisincruzan. My PDM60 continues to work just fine in default mode. I was simply hoping to change some of the time delays. Not a big deal.
 
1 - 20 of 20 Posts
Top