BMW K1600 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
New to this forum so my apologies if I repeat what is here. 2012 GTL, brake handle goes to the handle bar with very little resistance. Bled the brakes, did not see any air. Not sure if the abs could be causing this, any suggestions for a diy er
 

·
Premium Member
Joined
·
6,629 Posts
You state you bled system. Assume you didn't flush the system. Start with flushing the entire system.

Duane
 

·
Registered
Joined
·
2,884 Posts
was it going to the bars already?

also if you let the master get empty thats a pain, the small bleed nipple (next to the reservoir) does help
 

·
Premium Member
Joined
·
5,944 Posts
If it worked before then something changed while bleeding the brakes. Did you happen to run the reservoir dry while bleeding the brakes? If so I would remove the top cap on the reservoir and look at the fluid when you pull the brake lever. See if there is any movement in the fluid like fluid being circulated back into the reservoir. If so you will want to disconnect the lines, remove the reservoir system, tear it apart and clean everything then reassemble. You could have contaminants in the system that isn't letting the pressure go to the brake lines but instead is going through the bypass circuit back into the reservoir.

This is assuming there is a bypass circuit of course.
 

·
Registered
Joined
·
1,917 Posts
Maybe go back to step one. Are either front or back pads down to nothing? If so, you'll first need to replace the pads and then do a flush and fill. If that doesn't bring the brake lever back to normal, you've got some issues you need to troubleshoot.
 
1 - 6 of 6 Posts
Top