BMW K1600 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Let me tell you the sound quality is amazing couldn't be happier! Amazing piece of kit for sure.... Anyway just for giggles I thought I would try to pair this unit to the bike Radio and Navigator VI and I'm getting nowhere (2019 K1600GT). I can pair it to my iPhone 8 and the GPS perfectly and easily. So here is the procedure I tried to use.


Cleared the Cardo with a reset, Cleared bike and GPS of all previous connections, turned off all near-by Blue tooth devices.
  1. Pair the Cardo Packtalk to HELMET A on Cardo Channel 1. Cardo reports back successfully paired, music plays from radio thru headset.
  2. Switched the bike OFF, but keep Navigator VI powered on.
  3. Selected Bluetooth (check mark) and Discoverable (check mark)
  4. Placed Cardo into GPS pairing mode, select pin codes etc..... and Cardo reports back successfully paired.
  5. Turned on iPhone 8 and completed steps to successfully connect iPhone to GPS, Navigator app for music will play thru Cardo headset.
  6. Powered downed Navigator VI switch bike ignition back and GPS and iPhone connects to GPS, "Helmet A" NEVER connects again "B symbol on dash" light just blinks.
Is this a known bug or am I doing something wrong? I'm totally perplexed......


Thanks guys
Greg
 

·
Premium Member
Joined
·
84 Posts
Greg,
I went through similar thing two weeks ago when was pairing my just purchased Packtalk Bold to my 2018 GTL. Had initially exactly same frustrating experience as you describe of the Packtalk losing its memory of its prior successful pairing. Found the problem by carefully re-reading the installation cheat sheet that comes with the Packtalk as well as the more detailed pdf manual version on their website. (See Page #7 of manual.) To pair a GPS device, you need to do two steps of button pushing on the Packtalk, step two is to “roll the control wheel forward “ if the second device is a GPS device (the NAV6). When I had skipped “rolling the control wheel forward “, I got exactly your behavior of losing the formerly working connections after recycling the power button. When I rolled the wheel forward, all was well.

By the way, I pulled my NAV6 out of the bike and plugged it into a built in USB wall outlet in my office and did all the pairing experiments at my desk. (Note that not all USB outlets will power up the NAV6, some wall adapter USB outlets and for sure all computer USB ports will just kick it into its mass storage mode, which I started a thread on a few weeks ago. )
Ken


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3 (Edited)
Ken,
Thank you for the reply. You absolutely nailed it. What I was doing wrong on the PACKTALK SLIM is missing one step. I was pressing the phone button for 5 seconds and then pressing the + (plus) button. What I was neglecting to do after the 5 second hold is press the phone button twice quickly which puts the unit into channel 2 then press the + button to designated GPS pairing. Once I did that everything synced up well. Again, thank you for your help, greatly appreciate you taking the time to reply.


Thanks
Greg
 

·
Premium Member
Joined
·
84 Posts
Greg, you are welcome. Gives me something to do while in Thailand providing support to stepson who is in ICU unit of local hospital with severe bacterial infection in leg. Could be here for weeks. Ken


Sent from my iPad using Tapatalk
 

·
Premium Member
Joined
·
269 Posts
Greg, you are welcome. Gives me something to do while in Thailand providing support to stepson who is in ICU unit of local hospital with severe bacterial infection in leg. Could be here for weeks. Ken


Sent from my iPad using Tapatalk
That's rough my friend. Good luck to your stepson. He is fortunate you are able to be there to provide support.

Duke
 

·
Premium Member
Joined
·
1,855 Posts
Greg, you are welcome. Gives me something to do while in Thailand providing support to stepson who is in ICU unit of local hospital with severe bacterial infection in leg. Could be here for weeks. Ken


Sent from my iPad using Tapatalk
Prayers for his healing and wisdom for the medical team caring for him.
 

·
Premium Member
Joined
·
84 Posts
Thanks for your support regarding my stepson in Thailand hospital, I don’t want to hijack this thread, but his recovery speeded up dramatically after our arrival and switching him from the hospital for the “have-nots” to the “haves” hospital, about five blocks apart, but in two different worlds. This new hospital is shocking modern and well staffed, heads and shoulders above any hospital I’ve seen in the US. And at fraction of the cost of US. Stepson is uninsured (failed to buy travel insurance )but our cash cost at 100% is probably less than what the deductible/copay would be in US. This is day #14 in the hospital, today he moves out of ICU into a general room, and will go off of intravenous antibiotics in 4 days if all goes well. Do NOT ever get a bacterial infection in the tropics, it can be life threatening, destroy internal organs, is aggressive and very difficult to battle even with state of the art medical care!
Ken
 
1 - 7 of 7 Posts
Top