BMW K1600 Forum banner
  • Hey Everyone! Vote for the Site Favourite BOTM winner for the year of 2021 HERE!
1 - 12 of 12 Posts

·
Premium Member
2013 K1600GTL
Joined
·
164 Posts
Discussion Starter · #1 ·
Hi all,
My service light came on. Bike just hit 45,000 miles. I have the OBD reader, not the GS and I reset for oil changes, 400 miles since last one. What are the other reasons the light comes on? I hooked it up, but I didn't get any reasons.
Any advice would help.

Duff
 

·
Premium Member
2013 K1600GTL
Joined
·
164 Posts
Discussion Starter · #3 ·
Yeah, I have all this. I thought I checked all the menus, but nothing came up as far as something that needed to be reset or checked on. I'll try again, but was wondering if their was a small list of what triggers the light.

Duff
 

·
Registered
2012 K1600 GT
Joined
·
39 Posts
There are different subscription levels of Motoscan that give you deeper access to codes/resetting/maintenance functions etc, and it works with a old scanner.

If you do not want to do it all yourself, you may reach out and see if there is a GS911 available from another member close to you that would be willing to give up a VIN slot to read what the fault code is. I would recommend finding what the fault is as soon as possible. Good luck.
 

·
Mr.Fix It
Joined
·
8,725 Posts
There are 2 triggers for the light; mileage and date, whichever comes first.

Duane
 
  • Like
Reactions: 1004ron and coyotek

·
Premium Member
2013 K1600GTL
Joined
·
164 Posts
Discussion Starter · #9 ·
Excellent answer! I'll check that. Thank you.

Duff
 

·
Registered
2013 GTL
Joined
·
1,314 Posts
Excellent answer! I'll check that. Thank you.

Duff
Please do a screen capture as found, as left, and post it here.

I also use Motoscan and set my mileage interval at 4K and time interval at 12 months.

Don't forget to subtract the 400 miles already traveled since the service.

Font Screenshot Software Technology Multimedia
 

·
Premium Member
2013 K1600GTL
Joined
·
164 Posts
Discussion Starter · #11 ·
I'm almost positive changing the date will fix it. I know I set the mileage, but I don't think I changed the date.

Duff
 

·
Registered
Joined
·
2 Posts
I'm almost positive changing the date will fix it. I know I set the mileage, but I don't think I changed the date.

Duff
I ran into this very problem a bit ago. I KNOW I had set the mileage and date, however, I missed checking the motorcycle's current date. It was over a year old. Not sure how that happened, but after I set the current date all was good.
 
1 - 12 of 12 Posts
Top