BMW K1600 Forum banner

1 - 20 of 120 Posts

·
International Man of Mystery
Joined
·
3,196 Posts
Discussion Starter #1 (Edited)
Shift assist stopped working at around 21000 km on my 2018 MY GTL. Experienced some hard shifting occasionally, but now it is completely out of order. Nice in way that I can go back to normal shifting. Bike will go back to the dealer a few days after the 20.000 service was done, timing sucks.
 
  • Like
Reactions: Geoff_3

·
International Man of Mystery
Joined
·
3,196 Posts
Discussion Starter #2
Update on the shift assist

Well, after about one week of trying to make it work (replaced SA actuator, checked the interlocks like clutch sensors etc.) BMW found out that they cannot teach the BCM (a module that controls a large number of function of the bike outside the scope of the ECM) which in turn does not allow the SA to function properly. Mothership is involved, but no answer yet. Took the bike with the reassurance that it will be perfectly OK to take it on my vacation trip. Off I go now with the bad feeling in my head, that something in the hidden parts of electronics is screwed up and will bite my in the ass at the most inconvenient time.
BMW has a problem with quality control for sure.
 

·
Premium Member
Joined
·
3,723 Posts
Sorry to hear you're having such a problem. Computer to computer communication is a hard thing to diagnose, especially when their manual sucks, and the techs don't know squat about how to diagnose the problems. A one week class from a good instructor could do wonders for most of these techs. GM has an awesome training program that is not only available for techs, but can be accessed for free online by most anyone willing to register for the classes. I've been to a few BMW car training programs that consisted of an 8 hour, one day course, and it can be overwhelming trying to cover so much material in such a short amount of time. The hands on part of the classes were mainly watching the instructor do testing on a car that was practically new and had no real problems, except for those intentionally put into it for the class. Ask your tech sometime what he found when he checked the hi and low circuits for the can. Doubt the tests were ever done.
Best of luck with this. Let us know how it goes.
 

·
Registered
Joined
·
842 Posts
Did you ever get resolution on this? I was out riding today with just under 3K miles on my 2018 GTL and the shift assist just quit working. Shifted normally with the clutch. Stopped and turned bike off and started up again and shift assist was working again. It happened twice during a ~30 mile ride, lots of shifting up and down.

I haven't yet bought a GS911, so I don't know if this would throw a fault code; but it sure seems like it's related to firmware since it corrects when the bike is restarted. Dealership is over an hour away, so hard to just pop in if it happens again.

I'm also wondering if it might be the clutch sensor switch.
 

·
International Man of Mystery
Joined
·
3,196 Posts
Discussion Starter #5
After several weeks of tearing into the bike again the dealership concluded that it was a broken wire in the harness. In the mean time I decided to give up on this bike and traded it in for a 2018 GT. They worked with me and took the bike back.The financial impact was manageable and the GT performs without a flaw.
 

·
Premium Member
Joined
·
280 Posts
Mine seems to be going out too. '18 GTL with 32,000. Pretty much every time now it starts out working and then quits at some point.
 

·
Registered
Joined
·
842 Posts
Mine seems to be going out too. '18 GTL with 32,000. Pretty much every time now it starts out working and then quits at some point.
At least if it's consistent, you can show the dealership. Should be under warranty for you. If you take it in, let me know what they say it is. Mine's under warranty, but I'm not sure I can show it fail for the dealership.
 

·
Registered
Joined
·
125 Posts
2018 bagger I'm at 12,000 km and the quick shift stopped by 2000 km ago I haven't brought it in yet to be looked at

Sent from my Pixel 3 XL using Tapatalk
 

·
Preema
Joined
·
891 Posts
I should check mine as I dont know if its working. I still match revs when I clutchless shift, up and down and have been doing that for decades now. It's second nature, purely automatic...
 

·
Registered
Joined
·
842 Posts
I should check mine as I dont know if its working. I still match revs when I clutchless shift, up and down and have been doing that for decades now. It's second nature, purely automatic...
When mine went out, I had to use the clutch. It would not shift when matching revs manually with the throttle. I tried it just to see what would happen, but couldn't.
 

·
Registered
Joined
·
842 Posts
@justcharlie It may not generate a code but chances are the ECU will note a failure and some basic data like mileage, time code and the number of times detected.
Clearly, it's time to buy a GS911 - something I've been planning on anyway.
 
  • Like
Reactions: K16guy

·
Registered
Joined
·
842 Posts
Went for a ride this morning and had the same failure. It was toward the end of a 45 minute ride with lots of shifting. I pulled over and shut off the engine, but left the power on and still in failure mode after restarting. Stopped again and turned the power off and proper function restored upon starting up again. Maybe it won't be so hard to show it to the dealership.
 

·
Registered
Joined
·
1,903 Posts
My 18 B has failed to quickshift between 5th and 6th a few times when attempted over 80mph. Works flawless at lower speeds.

I've wondered if it's related to my throttle position. According to the owner manual the throttle must be in a stationary position to upshift, closed position to downshift. I want to make sure it's not operator error before i complain to dealer.

Sent from my SM-J327T using Tapatalk
 

·
Registered
Joined
·
125 Posts
Gs911 shows I have 3 fault codes to do with shift sensor voltage
Will have to bring it in for service

Sent from my Pixel 3 XL using Tapatalk
 

·
Registered
Joined
·
79 Posts
Well, it seems to be spreading.
About half way through a 6 hour ride back home yesterday mine packed up on the upshifts, but still auto blipped on the downshifts, then that failed about 20 miles later.
Riding the bike manually reminded me how clunky BMW gearboxes are, even Guzzis are better.



I'll have to see if an overnight rest has restored it.
 

·
Premium Member
Joined
·
446 Posts
Interesting. My 2016 GS has shift assist but I rarely use it. Mostly because I forget.

When I bought my ‘16 GT I was really looking for a ‘17 or newer to get the SA, reverse and updated styling (since I owned a 2012 in the past). Had I gotten the newer GT, I planned on spending the $300+ to get the mapping change for more hp. All became a moot point when I found my 2016.
 

·
Registered
Joined
·
125 Posts
In case anyone wants to know, mine failed at around 10,500 to 12,000km (don't use it much)
EDIT: Looking at the codes 12,183 is when it happenned :)
Bought bike in Sept, hit those km in Feb

Here are the error codes

Fault Codes : 3
|
3A1193 : Shift lever sensor, erroneous voltage
Currently present : YES
Engine warning light (MIL) : NO
Frequency count : 255
Logistic(Healing) count : 40
..Fault Code History :
....Record number : 1
....Odometer : 12182.0 km
....ABS time : 1080918
....SAE Code : 0
....Unknown : t-1101
|
3A1192 : Shift lever sensor, implausible voltage
Currently present : YES
Engine warning light (MIL) : NO
Frequency count : 255
Logistic(Healing) count : 40
..Fault Code History :
....Record number : 1
....Odometer : 12183.0 km
....ABS time : 1080986
....SAE Code : 0
....ADC voltage Gear lever position sensor channel 1 : 1.34 V
....ADC voltage Gear lever position sensor channel 2 : 2.99 V
....Gear position sensor voltage, Sensor 1 : 2.92 V
....Angle of Gear lever position sensor adapted to Neutral : -1.28 %
....Record number : 2
....Odometer : 12187.0 km
....ABS time : 3734881
....SAE Code : 0
....ADC voltage Gear lever position sensor channel 1 : 1.25 V
....ADC voltage Gear lever position sensor channel 2 : 4.98 V
....Gear position sensor voltage, Sensor 1 : 3.83 V
....Angle of Gear lever position sensor adapted to Neutral : -1.28 %
....Record number : 3
....Odometer : 13541.0 km
....ABS time : 7711568
....SAE Code : 0
....ADC voltage Gear lever position sensor channel 1 : 1.16 V
....ADC voltage Gear lever position sensor channel 2 : 4.98 V
....Gear position sensor voltage, Sensor 1 : 3.84 V
....Angle of Gear lever position sensor adapted to Neutral : -1.28 %
|
3A1190 : Shift lever sensor, voltage above threshold
Currently present : YES
Engine warning light (MIL) : NO
Frequency count : 255
Logistic(Healing) count : 40
..Fault Code History :
....Record number : 1
....Odometer : 12187.0 km
....ABS time : 3734881
....SAE Code : 0
....ADC voltage Gear lever position sensor channel 1 : 2.49 V
....ADC voltage Gear lever position sensor channel 2 : 4.98 V
....Gear position sensor voltage, Sensor 1 : 3.84 V
....Angle of Gear lever position sensor adapted to Neutral : -1.28 %
....Record number : 2
....Odometer : 12188.0 km
....ABS time : 3734926
....SAE Code : 0
....ADC voltage Gear lever position sensor channel 1 : 0.85 V
....ADC voltage Gear lever position sensor channel 2 : 4.98 V
....Gear position sensor voltage, Sensor 1 : 3.83 V
....Angle of Gear lever position sensor adapted to Neutral : -1.28 %
....Record number : 3
....Odometer : 13541.0 km
....ABS time : 7711568
....SAE Code : 0
....ADC voltage Gear lever position sensor channel 1 : 1.16 V
....ADC voltage Gear lever position sensor channel 2 : 4.98 V
....Gear position sensor voltage, Sensor 1 : 3.83 V
....Angle of Gear lever position sensor adapted to Neutral : -1.28 %
 
1 - 20 of 120 Posts
Top